DELHI PUBLIC SCHOOL, DURGAPUR

/<7 QUESTION BANK & REVISION SHEET OF COMPUTER FOR FINAL EXAMINATION (2017-18)
CLASS-VII
COMPUTER

C++ Programs(CONDITIONAL CONSTRUCTS & LOOPS)

Q.1WAP to accept any three number and display greatest among them.

Q.2 WAP to accept any number and display first ten multiples of that number.

Q.3 WAP to accept any five numbers and display their sum and product using loop.
Q.4WAP to generate following pattern:-

a)

*

* *

* * *

* * * *
b)

1

1 2

1 2 3

1 2 3 4
c)

1

2 2

3 3 3

4 4 4 4
d)

1

2 3

4 5 6

7 8 9 10
e)

1

1 0

1 0 1

1 0 1 0

Q.5 WAP to accept any two numbers and perform following operations and give result based on user’s choice (Menu
Drive Program):-
a) Add b)Subtract c)Multiply d) Divide
Q.6 WARP to accept any number and check whether it is positive or negative.
Q.7 WAP to accept any number and check whether it is odd or even number.
Q.8 WAP to accept any character and check whether it is vowel or not.

Find out errors in following programs:-

1) #include<iostream.h>
#include<conio.h>

void main();
{
clrscr();
inta,b;
cout<<"Enter the value of a";
cin>>a;

cout<<"Enter the value of b";
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cIn<<b;
if(a>b);
{

}

else if

{

}
getch()

cout<<"value of b is more than a";

cout<<"value of ais more than b";

¥

2)include<iostream.h>
#include<conio.h>

void main()
{
inta
cout<<"Enter the value of a ";
cin<<a;
if(a%2=0)
{ _
cout<<a<<"is even number";
}
else
{
cout<<a<<"is odd number";
}
getch();
}
}

3) #include<iostream.h>
#include<stdio.h>
void main();

clrscr();

int a;

cout<<"Enter the value of a";
cin>>a;

if(a>=1)

{

¥

else (a<0)

{
¥

else

{

cout<<"a is a positive number";
cout<<"a is a negative number";

cout<<"a is zero";

b
getch()
)

4)#include<iostream.h>
#include<conio.h>
void main()

clrscr();
int i=1, num=3, res;
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While(i<=10)

{
res=i*no;
cout<<result<<endl;
i+;

}

getch();

5)#include<iostream.h>
#include<conio.h>

void main()
{
clrscr();
int i=1; num=3; res,
do;
{
res= i*num;
cout<<res<<endl;
i++;
}
while(i<=10)
getch();
}

6)#include<iostream.h>
#include<conio.h>
void main()

clrscr();
int num=3,i,result;
for(i=1;i<=10;i++);

{ .
b=i*num;
cout<<a<<"*"<<j<<"="<<result<<endl;
}
getch();

Predict the output of the Following programme:-

1) #include<iostream.h>
#include<canio.h>
void main();

clrscr();
int a,b,c;
cout<<”Enter any three numbers:”;
cin>>a>>b>>c;
if((@>b)&(a>c))
{

a=a*b*c;
cout<<’New value of ais:"<<a;

}o
else if(b>c)

b=a+b+c;
cout<<’New value of b is:”<<b;

else

c=(at+b)/c;
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Cout<<”"New value of c 1S: C,
}
getch();
}

Note: If value of a,b,c are respectively-5,2,7 then predict the output

2) #include<iostream.h>
#include<canio.h>
void main();

clrscr();
int a,b;
cout<<”Enter any two numbers:”;
cin>>a>>Db;
if(a>b)
a=(a*2)/5;
cout<<’New value of a is:"<<a;

else

b=(a+5)/3;

cout<<’New value of b is:”’<<b;
}
getch();
}

Note: If value of a and b respectively 5,10 then predict the output.

Answer the following Questions:-

1)Write the syntax of if-else construct.2) Write the syntax of ‘if-else if ‘construct . 3) Differentiate between the if-else

and if-else if statements.4)Define Loops.5) What are the different types of loops ‘or’ define each types of loops.6)Write
the Syntax of ‘while’, ‘do while’ ‘for’ loop. 7) Discuss the advantage of using loops. 8)Differentiate between the ‘wile
Loop’ and the ‘do while’ loop.

Chapter-Storing Information Effectively.
1. FILL IN THE BLANKS:-

a)DBMS stands for .

b) is one of the most common types of DBMS.
c) The Blank database option is available under the section.

d) By default, database has an empty table named as .

e) is a view that allows you to modify the structure of a table.

f) The data type stores short alphanumeric values, text or a combination of both.

g) The data type stores substantial alphanumeric text, such as notes and description.
h) The data type stores values like the price of a product.

i)A is an empty table that can be used as it is, or modified as per need.
j) The helps to identify and quickly search particular details in a table.
k) The Primary key cannot have values.

2. CORRECT THE UNDERLINED ERRORS:-

a) The Primary Key icon is available in the Create tab.

b) By default, Microsoft Access sets the any column of a table as the Primary Key.

c) A table can have more than one column set as the Primary Key, which is used identify a record.
d) Design View is the default view of a table, which shows the records in a table.

e) A column represents a set of related information about a particular entry in a table.
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T) Datasheet View is available under the Tools tab.

g) Design View allows you to add or modify the records.

h) The Primary Key in a database is used to connect two tables.

i) the Relationship button is available under the Create tab.

j) The_ Cascade Update Related Fields rule prevents you from entering a value in the Foreign Key field if a
corresponding value does not exist in the Primary key.

k) The Enforce Referential Integrity rule allows updating all the related Foreign key values, if the Primary key value is
modified.

3. STATE TRUE OR FALSE:-

a) In Microsoft Access 2010, the Blank database option is available in the New Blank Database section.

b) You should click the folder icon next to the File Name text box to change the default save location.

c) Information in a database is not stored in different rows and columns.

d) While saving a database, its name is entered in the File Name Text box.

e)Microsoft Access is a kind of RDBMS.

f) A database can have more than one table.

g) In Design View, you can specify only one Field Name and Data Type for a particular column.

h) The Date/Time data type stores the date and time values, such as Date of Birth and Date of Joining.

i) A data type refers to the type of data that can be stored in a column of a table.

j) Data types cannot be changed for a column in a table.

k) The Primary key is a row in a table which has unique values.

4. ONE WORD ANSWER:-

a) Which kind of software is Microsoft Access?

b) The Primary Key is available in which tab?

¢) Which type of values hold by a Primary key field?

d) By default which table appears in a newly created database?

e) Which short cut key we use to save a table?

f) What we specify within a Design View?

g) Which data type stores substantial alphanumeric values?

h) Which data type stores Boolean values?

i) Which option is provided by Ms Access to create table quickly?

J) What is the default view of a table?

k) Which key is considered as a Primary key of another table?

5. ANSWER THE FOLLOWING QUESTIONS:-

a) What is Database?

b) What is Database Management System?

¢) What is Relational Database Management System?

d) Name some database now days in use.

e) What is Virtual Table?

) Define-i>Table, ii>Record, iii>Field, iv>Cell.

g)What is Design View?

h) What is Data Type? Define each type of Data.

i)What is Table template?

Jj) what is Data Sheet View?

k) Differentiate between Design View & Datasheet View.

1) What is Primary Key? Define 2 of its features.

m) What is Foreign Key?

n)Define the rules which we implement to maintain the relationship of a table. Or
Define-i. Enforce Referential Integrity, ii. Cascade Update Related Fields. iii. Cascade Delete Related Records.
0) Differentiate between Cascade Update Related Fields & Cascade Delete Related Records.

Chapter-Retrieving Data From Database.

2. FILL IN THE BLANKS:-

a) To close the Find and Replace dialog box, you should click
b) To arrange the Records in the increasing order, you should select the
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C) To filter the Records in the table, we can click on the drop-down arrow next to the name.
d) The group has the Options to arrange the records in the ascending or descending order.

e) To search the Required details in a table, click the button.

f) The dialog box allows us to add multiple tables in the query window

g) Query design allows us to customize our , thereby providing more control over a query.

2. STAE TRUE OR FLAS:-

a) We cannot search a particular record in a table.
b) To arrange records in the ascending or descending order, you need to filter them.
c) To search the details in a table, open the table in Datasheet View.

d) There is only one way to sort records in a table

e) Filter button is located in Home Tab.

f) The Criteria row allows us to specify any condition in a query.

g) We need to run the query created using Query Design.

3. CORRECT THE UNDERLINE ERRORS:-

a) The Home tab contains the Query Wizard option.
b) The Existing Query dialog box opens when we click the Query Wizard option.
c) A query isa Table object used to retrieve specific information from the database.
d) To save a query, click on the Save button.
e) The Play button in the Result group must be selected to execute a query.

f) The Query name appears by default when we select Field in the table row.
g) The File tab contains the Query Design option.

4. ONE WORD ANSWER:-

a) Which object we use to retrieve information from database?

b) Which group contains Query Wizard Option?

c) Which option provides step-by-step approach to create a query in the database?
d) On which button we use to click in order to move the fields from Available Fields to Selected Fields?
e) If the table name is Details, then what will be the default query name?

f) Which value checks a particular field for null values in a table?

g) Which Dialog box opens when we click the Query Design Option?

5. ANSWER THE FOLLOWING QUESTIONS:-

a) Write the ways to mange records and retrieve specific information from the Database.
b) Define- i>Searching, ii> Sorting, iii> Filter Option.

¢) Write the steps of Searching Records.

d) Write the steps of Sorting Records.

e) Write the steps of Filtering Records.

f) What is Query?

g) What is Query Design?

h) What is Query Wizard?

i) What is the Use of Show Table dialog box.

j) Define Criteria Row.

k) Define the Is Null value.

I) Differentiate between Query Wizard and Query Design.

m) Write the Steps to create a Query in Query Design View.

n) Write the steps to create a Query in Query Wizard.

Chapter-Designing Forms and Reports

1. FILL IN THE BLANKS:-
a) The Form Wizard button is available in the

b) A is a database object that allows us to enter, change and view data in a database.

c) The Add All button moves all fields from Fields to Selected Fields.

d) Toolbar contains the Save button to save a form.

e) The Navigation Bar shows the number of records in a table.

f) The Add Existing Fields button in the group of the Design tab must be selected to add a field.
g) Use the option in the Format tab to add a background image in the report.

h) The Print Preview option is present in the group.

i) The group is present in the Design tab.
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2.

a)
b)
c)
d)
€)
f)
9)
3.
a)
b)
c)
d)
e)
f)
9)
4

a)
b)
c)
d)
e)
f)
9)
5

STATE TRUE OR FALSE:-

Form Wizard in Microsoft Access provides a step-by-step approach create a form.

Control group contains the Form Wizard button.
The Form Data dialog box appears when we click the Form Wizard button.

It is not possible to add a new blank record using Record Navigation Bar.
The Record Navigation bar appears at the top of the Microsoft Access window.

Label control is used to display text in reports.

An image can be added to a report by selecting the Background Image option from the Format tab.
CORRECT THE UNDERLINE ERRORS:-

The field List pane appears on the left side of the screen.

The multiply icon must be clicked besides the table in Field List to display names of all the tables in the database.
You can Double —click a table name to view the fields in the table.

Data cannot be modified when we create report using Report Wizard.

Report is a database object used to view and summarize data in a readable format.

We cannot add footers to our report.

Print Preview cannot be opened through the File tab.

ONE WORD ANSWER:-

Which group contains the Form Design button?

Which View is used to view a form from the View drop-down in the Views group to view a form?
Which group contains the Report Wizard button?

Name the drop-down list from which the table to be modified using report Wizard must be selected?
What is the default layout in Report Wizards?

Which tab contains Background Image option?

Which tab is used to format a report?

ANSWER THE FOLLOWING QUESTIONS:-

a) What isa Form?

b) Write the steps to create Form in Form Wizard.

c) Write the Steps to Create a Form in Form Design.
d) What is the use of Form Design button?

e) What is Report?

f) Write the Steps to add Label in a Report?

g) Write the steps to set Background image in a Report.
h) Write the steps to add Logo in a Report.

i) What is the use of Record Navigation Bar in Form?
J) Write the steps to create a report in Report Wizard.

Syllabus-
CHAPTERS NAMES

©xoNo G

USING CONDITIONAL CONSTRUCTS
PROGRAMMING USING LOOPS
STORING INFORMATION EFFECTIVELY
RETRIEVING DATA FROM DATABASE
DESIGNING FORMS AND REPORTS.
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